Probleme mit Outlook – Kennwort erforderlich

Ich hatte bei einem Kunden das Problem, dass sich das lokale Outlook nicht mehr mit dem Office365 verbinden ließ. Unten in der Outlook-Taskleiste erschien konstant die Meldung, dass ein Kennwort erforderlich sei. Wenn man auf die Meldung klickt, erscheint ganz kurz ein kleines Fenster, verschwindet aber dann auch sofort wieder.

Dinge, die ich probiert habe

Als ich die Meldung das erste Mal gesehen habe, dachte ich mir “ok, liegt vielleicht daran dass das Gerät mal wieder neugestartet werden muss”. Ein Neustart hat es aber leider nicht gebracht, genau so wenig wie der Start von Outlook im Safe-Modus (über Ausführen den Befehl outlook.exe /safe ausführen).

Eine Reparatur von Outlook hat nichts gebracht, genau so wenig wie ein neues Profil mit den Konten. Andere Konten konnten ebenfalls nicht angelegt werden, es kamen immer unterschiedliche Fehlermeldungen (Server nicht erreichbar, Upps da ist was schiefgelaufen, …).

Ich hatte denn irgendwann die Schnauze voll und habe das gesamte Office deinstalliert und wieder neu installiert. Und auf einfach… Verbindung und Outlook wieder nutzbar und einsetzbar. Hervorragend. Bis gerade, da hatte ich den Kunden wieder am Telefon, dass die Verbindung schon wieder nicht geht.

Ursache und Lösung

Ich habe mir das System dann gerade nochmal genauer angeschaut und festgestellt, dass Outlook aktuell die Version 1909 hat (Oben im Menü Datei => Office-Konto => Version). Ich habe von der RTM-Version installiert, damit lief es. Nach dem Update auf 1909 lief es wieder nicht. Scheint also irgendwie mit dem Update zusammen zu hängen bzw. es wurde irgendwas geändert, was nun nicht mehr funktioniert.

Nach einer kurzen Suche bin ich über folgende Diskussion bei superuser.com gestolpert (Outlook needs password but dialog box disappears), in der unter anderem dazu geraten wurde, die Authentifizierung von der “modern auth” auf die klassische Variante zurückzustellen. Das passte ziemlich gut mit meiner Beobachtung, dass ganz kurz ein Browser-Fenster aufgeht und sich direkt wieder schließt, zusammen.

Ich habe nun auf dem System, wie in dem Artikel beschrieben, die folgenden zwei Registry-Einträge erstellt:

  • HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Common\Identity
    • Neuer DWORD (32 Bit) Eintrag
    • Name: EnableADAL
    • Wert: 0
  • HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Common\Identity
    • Neuer DWORD (32 Bit) Eintrag
    • Name: DisableADALatopWAMOverride
    • Wert: 1

Nachdem ich diese Werte gesetzt habe und das Outlook neugestartet habe, kam direkt (im Outlook selbst, nicht in einem Browserfenster) die Passwort-Abfrage für das Konto. Kennwort eingetragen, Passwort speichern, Outlook verbunden.

Scheinbar ändert eins der Office-Updates etwas an der Anmeldung, so dass eine Anmeldung nicht mehr möglich ist. Ich hoffe dem ein oder anderen mit dem gleichen Problem hilft dieser Hinweis.

Jan

Jan Kappen arbeitet sein 2005 in der IT. Er hat seine Ausbildung 2008 abgeschlossen und war bis 2018 als IT-Consultant im Bereich Hyper-V, Failover Clustering und Software Defined Storage unterwegs. Seit 2015 wurde er jährlich von Microsoft als Most Valuable Professional (MVP) im Bereich "Cloud & Datacenter Management" ausgezeichnet für seine Kenntnisse und die Weitergabe seines Wissens. Jan ist häufig auf Konferenzen als Sprecher zu finden, weiterhin bloggt er viel. Seit September 2018 ist Jan als Senior Network- und Systemadministrator bei einem großen mittelständischen Unternehmen im schönen Sauerland angestellt. In seiner Freizeit kümmert er sich um das Freifunk-Netzwerk in Winterberg und Umgebung.

Ein Kommentar:

  1. Hallo Jan,

    ja der Hinweis hat mir sehr geholfen 🙂
    Vielen Dank

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.